[PATCH v2] ima: Fix function name error in comment.
unclexiaole at gmail.com
Fri Apr 9 01:20:37 UTC 2021
On 2021/4/6 10:12, Jiele Zhao wrote:
> The original function name was ima_path_check(). The policy parsing
> still supports PATH_CHECK. Commit 9bbb6cad0173 ("ima: rename
> ima_path_check to ima_file_check") renamed the function to
> ima_file_check(), but missed modifying the function name in the
> Fixes: 9bbb6cad0173 ("ima: rename ima_path_check to ima_file_check").
> Signed-off-by: Jiele Zhao <unclexiaole at gmail.com>
> security/integrity/ima/ima_main.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
> diff --git a/security/integrity/ima/ima_main.c b/security/integrity/ima/ima_main.c
> index 9ef748ea829f..03bef720ab44 100644
> --- a/security/integrity/ima/ima_main.c
> +++ b/security/integrity/ima/ima_main.c
> @@ -482,7 +482,7 @@ int ima_bprm_check(struct linux_binprm *bprm)
> - * ima_path_check - based on policy, collect/store measurement.
> + * ima_file_check - based on policy, collect/store measurement.
> * @file: pointer to the file to be measured
> * @mask: contains MAY_READ, MAY_WRITE, MAY_EXEC or MAY_APPEND
This is the [patch v2] based on your suggestion. Does this meet the
More information about the Linux-security-module-archive