[PATCH v2 -next 14/18] LSM: rename the inode fileattr hooks to path_file_* hooks
sashiko-bot at kernel.org
sashiko-bot at kernel.org
Thu Oct 15 12:40:26 UTC 2026
> The inode_file_getattr and inode_file_setattr hooks receive a struct
> path, so rename them to path_file_getattr and path_file_setattr to
> follow the path_* naming convention used for the other hooks that
> take a struct path (path_chmod, path_chown, ...). Rename the
> security_inode_file_getattr() and security_inode_file_setattr()
> inline wrappers and the SELinux and Landlock implementations
> accordingly.
>
> Assisted-by: opencode: glm-5.3
> Signed-off-by: Cai Xinchen <caixinchen1 at huawei.com>
Sashiko has reviewed this patch and found no issues. It looks great!
--
Sashiko AI review · https://sashiko.dev/#/patchset/20261015125425.3246251-1-caixinchen1@huawei.com?part=14
More information about the Linux-security-module-archive
mailing list