[PATCH v2 -next 11/18] LSM: rename inode_setattr to path_setattr
sashiko-bot at kernel.org
sashiko-bot at kernel.org
Thu Oct 15 12:35:41 UTC 2026
> The inode_setattr hook receives a struct path, so rename it to
> path_setattr to follow the path_* naming convention used for the
> other hooks that take a struct path (path_chmod, path_chown, ...).
> Rename the security_inode_setattr() inline wrapper to
> security_path_setattr() and the SELinux, Smack, EVM and Landlock
> implementations accordingly.
>
> Assisted-by: opencode: glm-5.3
> Signed-off-by: Cai Xinchen <caixinchen1 at huawei.com>
Sashiko has reviewed this patch and found no issues. It looks great!
--
Sashiko AI review · https://sashiko.dev/#/patchset/20261015125425.3246251-1-caixinchen1@huawei.com?part=11
More information about the Linux-security-module-archive
mailing list