[PATCH v2 -next 12/18] LSM: rename the inode xattr hooks to path_xattr hooks
sashiko-bot at kernel.org
sashiko-bot at kernel.org
Thu Oct 15 12:39:44 UTC 2026
> The inode_setxattr, inode_getxattr, inode_listxattr and
> inode_removexattr hooks receive a struct path, so rename them to
> path_setxattr, path_getxattr, path_listxattr and path_removexattr to
> follow the path_* naming convention used for the other hooks that
> take a struct path (path_chmod, path_chown, ...). Rename the
> security_inode_*xattr() inline wrappers to security_path_*xattr()
> and the SELinux, Smack, EVM, IMA and Landlock implementations
> accordingly. The inode_post_setxattr and inode_post_removexattr
> notification hooks still take a dentry and keep their names.
>
> BPF programs attach to LSM hooks by name ("lsm/inode_getxattr",
> "lsm.s/inode_setxattr", ...), so update the BPF selftests to the new
> names.
>
> Assisted-by: opencode: glm-5.3
> Signed-off-by: Cai Xinchen <caixinchen1 at huawei.com>
Sashiko has reviewed this patch and found no issues. It looks great!
--
Sashiko AI review · https://sashiko.dev/#/patchset/20261015125425.3246251-1-caixinchen1@huawei.com?part=12
More information about the Linux-security-module-archive
mailing list