[PATCH v2 -next 13/18] LSM: rename the inode posix acl hooks to path_*_acl hooks
sashiko-bot at kernel.org
sashiko-bot at kernel.org
Thu Oct 15 12:39:50 UTC 2026
Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Low] smack: stale kernel-doc parameters in smack_path_set_acl
--
commit 86b58223ea4147721a6935310d93abd33d140861
Author: Cai Xinchen <caixinchen1 at huawei.com>
LSM: rename the inode posix acl hooks to path_*_acl hooks
This commit renames the inode_set_acl, inode_get_acl, and inode_remove_acl
hooks to follow the path_* naming convention used for other hooks that take
a struct path. It also updates the inline wrappers and the LSM
implementations accordingly.
> diff --git a/security/smack/smack_lsm.c b/security/smack/smack_lsm.c
> index 95799afbb5c9f..1a1e9f11939eb 100644
> --- a/security/smack/smack_lsm.c
> +++ b/security/smack/smack_lsm.c
[ ... ]
> @@ -1540,7 +1540,7 @@ static int smack_path_removexattr(const struct path *path,
> }
>
> /**
> - * smack_inode_set_acl - Smack check for setting posix acls
> + * smack_path_set_acl - Smack check for setting posix acls
> * @idmap: idmap of the mnt this request came from
> * @dentry: the object
> * @acl_name: name of the posix acl
> @@ -1548,7 +1548,7 @@ static int smack_path_removexattr(const struct path *path,
> *
> * Returns 0 if access is permitted, an error code otherwise
> */
> -static int smack_inode_set_acl(const struct path *path,
> +static int smack_path_set_acl(const struct path *path,
> const char *acl_name, struct posix_acl *kacl)
> {
[Severity: Low]
This isn't a bug, but the kernel-doc parameters for smack_path_set_acl do
not match the function signature. The function takes a const struct path
pointer, but the documentation still lists idmap and dentry.
Should these stale parameters be updated to document the path parameter and
prevent kernel-doc build warnings?
--
Sashiko AI review · https://sashiko.dev/#/patchset/20261015125425.3246251-1-caixinchen1@huawei.com?part=13
More information about the Linux-security-module-archive
mailing list