[PATCH v2 -next 15/18] LSM: rename inode_setsecctx to path_setsecctx
sashiko-bot at kernel.org
sashiko-bot at kernel.org
Thu Oct 15 12:37:32 UTC 2026
> The inode_setsecctx hook receives a struct path, so rename it to
> path_setsecctx to follow the path_* naming convention used for the
> other hooks that take a struct path (path_chmod, path_chown, ...).
> Rename the security_inode_setsecctx() inline wrapper to
> security_path_setsecctx() and the SELinux and Smack implementations
> accordingly.
>
> Assisted-by: opencode: glm-5.3
> Signed-off-by: Cai Xinchen <caixinchen1 at huawei.com>
Sashiko has reviewed this patch and found no issues. It looks great!
--
Sashiko AI review · https://sashiko.dev/#/patchset/20261015125425.3246251-1-caixinchen1@huawei.com?part=15
More information about the Linux-security-module-archive
mailing list