[PATCH v4 1/8] landlock: Rename quiet_masks to quiet_access
sashiko-bot at kernel.org
sashiko-bot at kernel.org
Fri Oct 2 12:50:07 UTC 2026
> The base stores the fs/net/scope quiet bitmasks in a struct access_masks
> field named quiet_masks. A following commit adds the sibling struct
> permission_masks field quiet_permission for capabilities and namespaces.
> quiet_masks drops the access category and keeps the type half ("masks"),
> while quiet_permission keeps the category and drops the type half, so
> the two read as an inconsistent pair.
>
> Rename the base field to quiet_access, giving the symmetric,
> category-named pair quiet_access/quiet_permission that also matches the
> UAPI handled_access_*/quiet_access_* naming. This is a
> no-functional-change rename.
>
> Cc: Günther Noack <gnoack at google.com>
> Cc: Tingmao Wang <m at maowtm.org>
> Reviewed-by: Tingmao Wang <m at maowtm.org>
> Signed-off-by: Mickaël Salaün <mic at digikod.net>
Sashiko has reviewed this patch and found no issues. It looks great!
--
Sashiko AI review · https://sashiko.dev/#/patchset/20261002124409.1277970-1-mic@digikod.net?part=1
More information about the Linux-security-module-archive
mailing list