[PATCH -next] apparmor: Use IS_ERR_OR_NULL() helper function
John Johansen
john.johansen at canonical.com
Tue Sep 10 06:22:29 UTC 2024
On 8/28/24 05:26, Hongbo Li wrote:
> Use the IS_ERR_OR_NULL() helper instead of open-coding a
> NULL and an error pointer checks to simplify the code and
> improve readability.
>
> Signed-off-by: Hongbo Li <lihongbo22 at huawei.com>
Acked-by: John Johansen <john.johansen at canonical.com>
I have pulled this into my tree
> ---
> security/apparmor/path.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/security/apparmor/path.c b/security/apparmor/path.c
> index 45ec994b558d..d6c74c357ffd 100644
> --- a/security/apparmor/path.c
> +++ b/security/apparmor/path.c
> @@ -130,7 +130,7 @@ static int d_namespace_path(const struct path *path, char *buf, char **name,
> /* handle error conditions - and still allow a partial path to
> * be returned.
> */
> - if (!res || IS_ERR(res)) {
> + if (IS_ERR_OR_NULL(res)) {
> if (PTR_ERR(res) == -ENAMETOOLONG) {
> error = -ENAMETOOLONG;
> *name = buf;
More information about the Linux-security-module-archive
mailing list