[PATCH 1/2] mm, treewide: Rename kzfree() to kfree_sensitive()
hannes at cmpxchg.org
Wed Apr 15 05:01:06 UTC 2020
On Mon, Apr 13, 2020 at 05:15:49PM -0400, Waiman Long wrote:
> As said by Linus:
> A symmetric naming is only helpful if it implies symmetries in use.
> Otherwise it's actively misleading.
As the btrfs example proves - people can be tempted by this false
symmetry to pair kzalloc with kzfree, which isn't what we wanted.
> In "kzalloc()", the z is meaningful and an important part of what the
> caller wants.
> In "kzfree()", the z is actively detrimental, because maybe in the
> future we really _might_ want to use that "memfill(0xdeadbeef)" or
> something. The "zero" part of the interface isn't even _relevant_.
> The main reason that kzfree() exists is to clear sensitive information
> that should not be leaked to other future users of the same memory
> Rename kzfree() to kfree_sensitive() to follow the example of the
> recently added kvfree_sensitive() and make the intention of the API
> more explicit. In addition, memzero_explicit() is used to clear the
> memory to make sure that it won't get optimized away by the compiler.
> The renaming is done by using the command sequence:
> git grep -w --name-only kzfree |\
> xargs sed -i 's/\bkzfree\b/kfree_sensitive/'
> followed by some editing of the kfree_sensitive() kerneldoc and the
> use of memzero_explicit() instead of memset().
> Suggested-by: Joe Perches <joe at perches.com>
> Signed-off-by: Waiman Long <longman at redhat.com>
Looks good to me. Thanks for fixing this very old mistake.
Acked-by: Johannes Weiner <hannes at cmpxchg.org>
More information about the Linux-security-module-archive