[PATCH v6 7/7] tpm: pass an array of tpm_bank_list structures to tpm_pcr_extend()

Jarkko Sakkinen jarkko.sakkinen at linux.intel.com
Wed Dec 5 00:14:17 UTC 2018

On Tue, Dec 04, 2018 at 09:21:38AM +0100, Roberto Sassu wrote:
> The new tpm_bank_list structure has been preferred to the tpm_digest
> structure, to let the caller specify the size of the digest (which may be
> unknown to the TPM driver).

Why is that? Didn't previous commit query these?

> +struct tpm_bank_list {
> +	u16 alg_id;
> +	u16 extend_size;
> +	const u8 *extend_array;
> +};

Naming is not good here. If this only for extending shouldn't that
be in the structs name?


More information about the Linux-security-module-archive mailing list