[PATCH RFC v3 1/7] proc: add proc_fs_info struct to store proc information

Djalal Harouni tixxdz at gmail.com
Fri Nov 10 10:32:55 UTC 2017


On Fri, Nov 10, 2017 at 11:26 AM, Alexey Dobriyan <adobriyan at gmail.com> wrote:
> On 11/9/17, Djalal Harouni <tixxdz at gmail.com> wrote:
>
>> +struct proc_fs_info {
>> +     struct pid_namespace *pid_ns;
>> +};
>
>> +static inline struct proc_fs_info *proc_sb(struct super_block *sb)
>> +{
>> +     return sb->s_fs_info;
>> +}
>
> Can you rename this to "struct proc_super_block *" then?
> That "info" suffix all over filesystems doesn't add much info itself
> just more typing.
> Ditto for "fs_info" identifiers.

Ok, will do.

>> +extern inline struct proc_fs_info *proc_sb(struct super_block *sb)
>> { return NULL;}
>
> extern inline?

Oups, sorry will fix it and try to compile without proc.

Thank you!

-- 
tixxdz
--
To unsubscribe from this list: send the line "unsubscribe linux-security-module" in
the body of a message to majordomo at vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html



More information about the Linux-security-module-archive mailing list